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SmartSketch Overview
SmartSketch®, formerly known as Imagineer™ Technical or Imagination
Engineer™, is the only desktop application that gives you the power to create
quick sketches, complex engineering designs, production drawings, plot plans,
schematics, business diagrams, and more.

• Industry solution templates with over 7,500 symbols

• Sketch ideas spontaneously and accurately, instantly transforming them into
precise CAD geometry

• What-if scenarios and testing real-world models reduce prototyping time

• Merge your designs with AutoCAD® and MicroStation®

• Add text and spreadsheets from Word, Excel, and PowerPoint; integrate
with popular databases

• Share drawing data across the World Wide Web

Industry Solutions
Get a quick start in projects with workflow templates tailored to dif ferent
industries including:

• Process: Process Flow Diagrams, P&ID, Electrical Schematics, Ortho Piping,
Control Loop, Process Block Diagramming

• Business Diagrams: Workflow Diagramming, Basic Diagramming, Off ice
Layout, Flowcharts, Organization Charts, Network Diagrams

• Network Diagram

• Technical Drawing

• Mapping: Atlas Mapping, Directional Mapping

• AEC: Architecture, Construction, HVAC, Plot Plans, Site, Landscape

• Mechanical:  Mechanical Drawings (ANSI & ISO)

SmartSketch Works with Leading CAD Products
Unlike most low-end sketching and drawing products, SmartSketch supports
major existing CAD environments such as AutoCAD® and MicroStation®. You
have full import and export capabili ties for traditional CAD data. In addition, you
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can work with .dgn and .dwg data in native formats—as if these formats were
OLE-enabled.

Acting as wrappers around foreign data, OLE servers allow you to simply drag
AutoCAD or MicroStation data into SmartSketch. You can even locate points in
the CAD geometry and work directly off those points in your SmartSketch
document.

This capabili ty—giving you live access to legacy data—makes SmartSketch a
powerful tool on your desktop.
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System Requirements
• SmartSketch requires the following software and hardware:

• Microsoft Windows 95 B, Windows 98, or Windows NT 4.0 with SP3 or
higher

• Microsoft Internet Explorer 4.0 or higher required to view Programming
guide.

• Pentium 133 microprocessor or higher

• 64 MB RAM recommended

• 70 MB disk space for minimum installation

• CD-ROM drive

• Sound Card recommended

• 800 x 600 resolution or higher

• Microsoft or Microsoft-compatible mouse (IntelliMouse® recommended)



Getting Started Chapter 1

5

Begin Using SmartSketch
1. Click Start on the Taskbar.

2. Point to Programs > Intergraph SmartSketch > SmartSketch.

Tip  You can also browse the Getting Started multimedia presentation. Point
to Programs > Intergraph SmartSketch > Getting Started.

3. When you start SmartSketch, a new document is displayed. This document is
based on the NORMAL.IGR template and has a drawing sheet.
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Creating a Drawing
.

1. Click File > New.

2. Choose a template for your drawing. Templates have the appropriate units,
scale, toolbars, and symbols to produce specific types of schematic or
precision drawings.
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User Interface Features
SmartSketch is an Office-compatible product, so the main menu and toolbar
have commands that are found in many other Windows products, like
Microsoft Word and Excel. For example, if you make a mistake and want to
undo what you just drew, you can click the Undo button, a button found on
the Main toolbar in most Windows products. The ribbon bars and dialog
boxes work just like those in Windows as well.

If you have trouble finding a button for a command, there is a way for you to
easily find it. When you place the pointer over a button on a toolbar, a small
yellow label, called a ToolTip, displays the name of the command.

Besides the standard Windows commands and tools, like horizontal and
vertical scroll bars, the SmartSketch window has several unique areas. The
following tools appear if you select the NORMAL.IGR template.

Menu bar The menu bar contains the names of all the
SmartSketch menus. You can click a menu name to
display a list of commands.

Main toolbar The Main toolbar has many of the commands you
will use to perform common Windows functions.
The toolbar also contains commands that you can
use frequently in SmartSketch.

Draw toolbar The Draw toolbar contains many of the commands
you can use to draw elements.



Chapter 1 SmartSketch Getting Started Guide

8

Ribbon bar The ribbon bar is a dynamic toolbar that displays
different options depending on which command you
are using. The options on each ribbon bar operate
much like the options on standard Windows dialog
boxes.

Drawing sheet The large portion of the window is the drawing
sheet, the area on which you can draw your design.
You can have more than one drawing sheet in a
document, sometimes called a file.

Sheet outline The sheet outline shows the orientation of the
drawing sheet and the printable region of the sheet.

Tabs The tabs allow you to display a sheet in your
drawing. The name of the active sheet is bold.

Tab scrolling buttons Tab scrolling buttons scroll through the sheets in the
drawing.

Symbol Explorer The Symbol Explorer on the right side of the
software window displays symbols that you can
drag into the document.

Attribute Viewer The Attribute Viewer appearing below the Symbol
Explorer displays attributes for selected symbols.
You can do many things with attributes, such as
modify the height or width of a symbol.
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Depending on which industry solution template that you select, different
toolbars and other items appear in the window, along with the standard tools
previously described.

Schematic toolbar The Schematic toolbar contains commands that
allow you to draw precision diagrams, such as the
Connector command and Grid Snap command.

Grid The grid allows you to place elements on the
drawing sheet with precision.

Title Block The title block allows you to enter information
about your drawing, such as your company name.

• On the Draw toolbar, click and hold the Circle By Center Point button. Some
command buttons display fly-outs when you click and hold the command
button. These buttons have a small black arrow in the lower right corner. Fly-
outs access commands that are closely associated with the button that you
clicked.

• On the Main toolbar, click the Dimension button. The Dimension button on
the Main toolbar accesses the Dimension toolbar. The Dimension toolbar has
buttons that you can use to place dimensions on your drawing.
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• Click the Change button. The Change button on the Main toolbar accesses the
Change toolbar. This toolbar has buttons that you can use to manipulate and
modify elements on your drawing.

• On the Draw toolbar, click the Symbols button. This button allows you to
create symbols.

• On the Draw toolbar, look at the Create Symbol button. This button allows
you to create symbols. This button is available only when you draw elements
and then select them.
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Industry Solutions and Templates
When you choose an industry solution template, SmartSketch creates a task-
specific environment that includes the following tools:

.

• Toolbars

• Sheet setup

• Symbols content

Toolbars
A schematic template, for example, includes the Schematic toolbar with tools you
need for that task.
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The drawing template, for example, includes the Drawing toolbar with tools for
drawing tasks.

Templates Control Sheet Setup
The template sets up the sheet for the file with the appropriate units, drawing
scale, line styles, fill styles, and borders for your project.
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Symbols Content
The Symbol Explorer displays more than 7,500 delivered symbols.

You can easily customize the Symbol Explorer by adding shortcut bars that point
to documents or web pages you use often.

Workflow Tutorials

To learn to use SmartSketch more efficiently, click Help > Learning Center. You
can step through a variety of tutorials tailored to different industries such as
process, AEC, business, mechanical, and more. These tutorials are designed to
get you up and running with the software.
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Learning to Use SmartSketch.
You can teach yourself to use SmartSketch with one of several on-line tools.

Getting Started
The SmartSketch Getting Started presentation provides information about the
software’s main features. To access the presentation, select the Taskbar and then
select the Programs menu. On the SmartSketch menu, click the Getting Started
program menu item.

ToolTips
SmartSketch displays ToolTips for the names of toolbar and ribbon bar options.
When you point the pointer at the command button on a toolbar or option on a
ribbon bar, a yellow label displays the command’s name.

Learning Center
The Learning Center is a series of multimedia tutorials and templates that
introduce you to key concepts, tools, and discipline-specific workflows.

• Click Help > Learning Center. You can choose from these options:

• Industry Solutions and Templates teach basic concepts for drawing.

• Workflow Templates demonstrate workflows geared to specific industries.

• Advanced Topics show you how to customize SmartSketch to fit your
workflow.

SmartSketch On-line Help
The SmartSketch on-line Help contains general information and specific
information about commands, dialog boxes, and procedures. The on-line Help
also contains overview information that is found in the SmartSketch Getting
Started Guide©.

If you are used to working with AutoCAD® or MicroStation®, you wil l find a
special Help section for AutoCAD and MicroStation users.

To access the complete set of Help topics, do the following:

1. On the Help menu, click SmartSketch Help Topics.
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2. On the SmartSketch Help dialog box, do one of the following to access
information:

• On the Contents tab, click the book icons to access general Help topics
and specific procedures. You can also access information about every
command in SmartSketch.

• On the Index tab, type a subject to search for topics.

• On the Find tab, type one or more words to search for topics that contain
those words.

To access Help for a particular part of the product, do one of the following:

• To access Help on a menu command or toolbar button, click the Help button
on the Main toolbar or press SHIFT + F1. The pointer changes to an arrow
with a question mark. You can then get context-sensitive help on a command
by clicking the button on the toolbar or the command on the menu.

• To access Help on a dialog box, click the Help button on the dialog box.

• If there is not a Help button on the dialog box, you can get Help on specific
parts of the dialog box by doing one of the following:

• Click the Question Mark button and then click an item on the dialog box.

• Place the pointer over a control and then click the right mouse button.

• Press F1 to get Help about the active item on the dialog box.

Programming with SmartSketch
SmartSketch provides complete guides to automating the product with any OLE
automation-aware product, such as Visual Basic® or VBA in Microsoft Excel.
The SmartSketch Programming Help includes an on-line user’s guide, on-line
automation reference guide, and programming samples to help you learn
automation with SmartSketch.

To read the SmartSketch Programming Help©, select Programming with
SmartSketch on the Help menu. You can access descriptions, syntax defini tions,
automation models, and examples of all the exposed objects, methods, and
properties from the Table of Contents. You can also activate the programming
samples from this guide. The programming samples demonstrate various ways in
which SmartSketch can be controlled using automation.



Chapter 1 SmartSketch Getting Started Guide

16

If You Need Assistance

Fast Access to Information
If you want information about support and registration, click SmartSketch on the
Web on the Help menu. You can get information about support, registering the
product, and training from the HTML pages.

You can also take the following steps:

1. In SmartSketch, on the Help menu, click SmartSketch Help Topics.

2. On the Help Topics dialog box, click the Index tab.

3. On the Index tab, type "support".

4. Click Display to get information about SmartSketch support.

Telephone
If you live in North America, for general information, call 1-800-345-4856 or
256-730-2000.

If you live in Asia-Pacific, Europe, the Middle East, or other foreign
countries, call 256-730-5441 or contact your local Intergraph sales office.
Refer to the ReadMe Help file for a complete list of local Intergraph sales
offices.

Mailing Address
Our mailing address is:
Intergraph Corporation
Huntsville, Alabama 35894-0001
U.S.A.
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SmartSketch for AutoCAD Users
If you are just getting started with SmartSketch and you already know AutoCAD,
there are some fundamental differences between the two packages that you
should review. Your familiarity with AutoCAD will help you learn SmartSketch
quickly, but you should review these conceptual differences and not try to use it
in exactly the same way you use AutoCAD. These differences are what make
SmartSketch productive, easy to use, and consistent with other Windows
applications.

Tip  Chapter 20 in this document describes what happens when you open an
AutoCAD document in SmartSketch. You can find detailed reference information
about this in SmartSketch Online Help. To open the online Help, start the
software and, on the Help menu, click SmartSketch On-line Help.

Working Environment
While SmartSketch does not use the same menu structure as AutoCAD, it does
follow Microsoft Windows and Office standards. Multiple views are provided
using standard Windows instead of viewports, and multiple documents can be
open at one time.

SmartSketch uses templates instead of prototype drawings to set up the working
environment (units, drawing scale, sheet size, etc.). See Chapter 18, Managing
and Printing Documents.

AutoCAD separates model space and paper space, however SmartSketch
combines these concepts using drawing sheets at a given scale. You can think of
each sheet as a separate drawing having unlimited layers, similar to a single
AutoCAD drawing file. SmartSketch files are called documents, each one having
multiple sheets. This is particularly useful in project management; the entire
project can be contained in one file or document. See Chapter 12, Working with
Measurements, Dimensions, and Variables, and Chapter 18, Managing and
Printing Documents.

Drawing Tools
SmartSketch uses “smart” commands and tools to reduce the number of
commands, icons, and pull downs. Snaps in AutoCAD have been replaced with a
more eff icient drawing aid in SmartSketch. SmartSketch® allows you to simply
pass the cursor across elements and receive visual feedback as to its position
relative to the element. See Chapter 5, Drawing Methods.

SmartSketch can remember relationships between entities. See Chapter 5,
Drawing Methods.
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Entities in SmartSketch are referred to as elements or objects. In order to
precisely place entities in AutoCAD, lengths, distances, and angles are typed at
the command prompt. SmartSketch provides common parameters on the ribbon
bar for most commands. The PinPoint tool allows you to accurately place
geometry relative to other geometry with minimal effort. See Chapter 10,
Arranging Elements.

SmartSketch provides a unique feature that allows you to select an entity from a
series of overlapping entities without having to zoom in. See Chapter 8,
Selecting, Moving, and Copying Elements.

SmartDimension is a tool that allows you to dimension any type of entity
accurately and quickly by simply selecting it with a single command. Dimensions
can be either driven, similar to AutoCAD associative dimensions, or driving.
When you change a driving dimension, the geometry is changed to reflect
dimensional changes. See Chapter 12, Working with Dimensions, Measurements,
and Variables.

Blocks and External Reference Files
SmartSketch symbols are very similar to AutoCAD blocks. Symbols are created
and inserted using standard OLE drag and drop instead of separate commands.
See Chapter 6, Using Symbols.

External reference files (XREFs) are supported in SmartSketch using an
extension to OLE called OLE for Design and Modeling (OLE for D&M).
SmartSketch can reference or link its own files and even native AutoCAD files
directly using OLE for D&M. See Chapter 20, Working with AutoCAD
Documents.

More Detailed Help
SmartSketch on-line Help provides a comprehensive comparison of commands,
terminology, and tasks in a special section called Help for AutoCAD Users.  To
open the online Help, start the software and, on the Help menu, click
SmartSketch On-line Help. On the Contents tab, click the Getting Started book or
click Working with AutoCAD Documents.
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SmartSketch for MicroStation Users
If you are just getting started with SmartSketch and you already know
MicroStation, there are some fundamental differences between the two packages
that you should review. Your familiarity with MicroStation will help you learn
SmartSketch quickly, but you should review these conceptual differences and not
try to use it in exactly the same way you use MicroStation. These differences are
what make SmartSketch productive, easy to use, and consistent with other
Windows applications.

Tip  Chapter 19 in this document describes what happens when you open a
MicroStation document in SmartSketch. You can find detailed reference
information about this in SmartSketch Online Help. To open the online Help,
start the software and, on the Help menu, click SmartSketch On-line Help.

Working Environment
While SmartSketch does not use the same menu structure as MicroStation, it does
follow Microsoft Windows and Office standards. SmartSketch windows work in
much the same way as MicroStation views, with the extension of allowing
multiple open documents. See Chapter 1, Getting Started with SmartSketch.

SmartSketch uses templates instead of seed files to setup the working
environment, such as units, scale, sheet size, and so on. See Chapter 18,
Managing and Printing Documents.

MicroStation uses reference files and drawing composition to produce a drawing
sheet. SmartSketch embraces this as a fundamental concept with drawing sheets
at a given scale. You can think of each sheet as a separate drawing with unlimited
layers, similar to a single MicroStation design file with levels. SmartSketch files
are called documents, each one having multiple sheets. This is particularly useful
in project management; the entire project can be contained in one file or
document. See Chapter 10, Arranging Elements, and Chapter 18, Managing and
Printing Documents.

Drawing Tools
SmartSketch uses “smart” commands and tools to reduce the number of dif ferent
tools, palettes, and pull down menus. SmartSketch does not use the concept of
snapping or tentative points to select keypoints on elements. This functionali ty is
built right into SmartSketch and keypoints are indicated next to the cursor as you
pass over them.

Elements in SmartSketch are often referred to as geometric elements or objects.
SmartSketch uses a double precision floating point database and does not require
you to set up master, sub, and positional units or limit the design plane. Unlike
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MicroStation, changing units in SmartSketch does not change the size of drawing
elements on the drawing sheet.

SmartSketch can remember relationships between elements. See Chapter 5,
Drawing Methods.

More Detailed Help
SmartSketch on-line Help provides a comprehensive comparison of commands,
terminology, and tasks in a special section called Help for MicroStation Users.
To open the online Help, start the software and, on the Help menu, click
SmartSketch On-line Help. On the Contents tab, click the Getting Started book or
click Working with MicroStation Documents.


